Ticket #102 (closed enhancement: fixed)

Opened 3 years ago

Last modified 2 years ago

Rename struct user

Reported by: guest Owned by:
Priority: normal Milestone: 0.6.0 "Hotspotify"
Version: 0.5.2 "WifiFree" Keywords:
Cc:

Description

The attached patch comes from the Ubuntu package. The description reads:

Rename struct user to struct _user in the code to avoid naming conflict caused by including <sys/user.h> as part of the armel build. Fixes FTBFS.

Please consider renaming the struct.

Cheers, gregor

gregoa@…, iodine maintainer in Debian

Attachments

armel_ftbfs.patch Download (1.2 KB) - added by guest 3 years ago.

Change History

Changed 3 years ago by guest

comment:1 Changed 2 years ago by yarrick

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to 0.6.0 "Hotspotify"
Note: See TracTickets for help on using tickets.